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1.

Introduction
Definition:

Aggregated Scale Morphological Interaction between a Tidal inlet and
the Adjacent coast (ASMITA).

This manual has been written as a guide to using the Matlab ASMITA model and
illustrates the concepts and methodology used in long-term morphological modelling.

1.1

Background Information
As part of the Estuaries Research Program Phase 2 (ERP2), funded by the
Environment Agency and Department for Environment, Food and Rural Affairs
(Defra), a long-term morphological prediction tool ASMITA has been developed. The
contributions from the following project partners are gratefully acknowledged
(Figure 1).





ABP Marine Environmental Research Ltd (ABPmer);
HR Wallingford;
Delft Hydraulics; and
Delft Technical University.

Figure 1.

1.2

Splash screen acknowledging the project partners who have
contributed to the ASMITA program

What is ASMITA and when should it be applied?
The idea behind ASMITA (Figure 2) is that a tidal basin, or any characteristic area
(element) evolves towards an equilibrium volume relative to tidal forcing. For
example, under conditions of an unchanging water level, an element is in static
equilibrium and the accommodation space is zero (no net change in the change in
the transport of sediment); with increased mean sea level, the estuary is no longer in
equilibrium, the accommodation space becomes positive and sediment may be
A.1

imported. The opposite is true when sea level falls. The key concepts of the ASMITA
model are:







The estuary is schematized into a number of geomorphologic elements;
The state of each element is described by its volume (water or sediment);
Integrated parameters of hydrodynamics (tidal prism, or tidal range) are used;
Empirical relationships define the morphological equilibrium for each element;
Deviation from the morphological equilibrium causes sediment demand; and
A gradient in sediment demand drives sediment transport, and thereby
morphological change.

Appendix A describes the theory and concepts used within the ASMITA model.

Outside world

Delta
Barrier
Channel

Barrier

Tidal flat
Figure 2.

A schematised representation of the concept of ASMITA

Due to the highly complex nature of estuaries, process based numerical models
struggle to describe the large number of variables needed to fully predict the longterm morphological response to changing environmental conditions. Often for such
models the required information is poorly understood, computational times are long
and sensitivity testing is very difficult to undertake.
ASMITA however, can be quickly applied to most systems and is capable of
providing rapid answers following an ensemble of test conditions. ASMITA can be
applied to investigate the long-term changes in morphology following some
perturbation to the system, such as the inclusion of realignment areas, climate
change and so on. As a general rule, ASMITA should be applied to support a range
of studies either as a stand alone or in combination with other assessment tools to
provide a greater degree of confidence in the long-term morphological predictions.
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1.3

About ASMITA Software
The ASMITA software has been written using the Matlab software language by
Mathworks, version R2008a (Figure 3). The software utilises only the functions
present within Matlab and does not require additional toolboxes. Distributed
alongside this manual is a document that details the relationships between the
various routines that make up the ASMITA program (Appendix A)

Figure 3.

1.4

The ASMITA program has been developed using the software
Matlab R2007a from Mathworks

Opening ASMITA
Within Matlab navigate to the folder containing the Matlab ASMITA scripts. From the
command line, type asmui; (Figure 4) this command will invoke the installation and
setup of the ASMITA graphical user interface (GUI).

A.3

asmui;

Figure 4.

To load and run ASMITA type ‘asmui;’ within the command
window

Global variables,
these contain the information
used for running ASMITA

Figure 5.

The Matlab environment after calling the ASMITA program

The information entered into the ASMITA model (type, properties, flow, diffusion
rates and so on) are contained within global variables stored within the Matlab
environment. This information is used throughout the various routines and stored in
memory throughout the lifetime of the application. The user can view this information
either through the graphical interfaces provided in the software (Section 9) or by
opening these global variables from the workspace window (Figure 5).
Note:

Within Matlab, information is stored as numbers, cell arrays and structured arrays.

A.4

Version and Menu
Options

Project name and scenario are
displayed here. This information
is entered by the user when
creating a new project.

Figure 6.

Project date, this is automatically
after creating a new project

The ASMITA interface

The user is able to control all aspects of the ASMITA model through the ASMITA
interface (Figure 6), there is no requirement for the user to access this data through
the Matlab command window.
Note:

Users have full access to the code that will enable them to make fine adjustments to the
controlling algorithms. For example, additional driving forces may be needed that are
not described in the current setup. Having full access to the software code allows the
user to add additional functionality.
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2.

File Operations
From within the ASMITA interface (Figure 6) there are a number of menu options.
The menu item FILE allows the user to perform a number of file operations such as
open or create a new instance of ASMITA, exit the program or save the current
model setup. The following section explains the options available to the user for each
of these items under the FILE menu.

2.1

New (Create a New Model Setup)
After selecting New from the File menu option a series of popup windows will appear.
The user is asked a number of questions regarding the project name and scenario
(Figure 7). This information will be displayed in the ASMITA interface (Figure 6).

Figure 7.

2.2

A dialog window appears after selecting the New menu item

Open (Open an Existing Model)
Information regarding existing ASMITA models can be stored within a Matlab work
file (*.mat). The *.mat file contains the information regarding the complete model
setup including element and system defined properties.

Figure 8.

Shows the dialog window that appears after selecting the Open
menu item, only *.mat files should be selected

A.6

Select an existing ASMITA model setup file from the common dialog box. By default
the *.mat file extension is visible (Figure 8). An example *.mat project is provided
along with the model scripts.

2.3

Save and Save As
The user can save the current setup of the ASMITA model by selecting Save or Save
As from the File menu item. If the user selects Save without first specifying a name
then the program will, by default, request a name from the user.

2.4

Exit
The user can exit the ASMITA program at any point by going to the Exit menu item in
the File drop down list.

3.

Tools
Within the ASMITA model software there are a number of tools designed to assist in
the building and visualisation of the model elements. Also included are a number of
tools that allow the user to clear unwanted figures or clear the whole ASMITA model
setup. These tools are described in more detail below.

3.1

Load Image
In order to understand the complexity of the system an image can be loaded as a
background map, showing the areas of intertidal, channel, delta and so on (Figure 9).
This can help the user visualise the schematised approach.

Figure 9.

The dialog box that appears after selecting the Load Image
option from the Tools file menu
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The user is able to select from the following image types:
ID Num
1
2
3
4
5
6
7

3.2

File Type
JPEG File Interchange Format (*.jpg, *.jpeg)
Tag Image File Format (*.tif)
Windows Bitmap (*.bmp)
Portable Network Graphics (*.png)
Hierarchical Data Format (*.hdf)
PC Paintbrush (*.pcx)
X Window Dump (*.xwd)

Refresh
The Refresh function updates the screen image, if an image appears incorrectly then
use the Refresh function to redraw the screen image.

3.3

Clear Model/Figures
The Tools → Clear → Clear Model function (Figure 10) resets all parameters in
ASMITA, allowing the user to start the process of setting up an ASMITA model
without the need to close the whole application.
Tools → Clear → Clear Figures function will delete any open plot windows (results
from. Under the Plot menu item (Section 9) the user can plot selected information in
numerous windows. To simply close all figure windows click the Clear Figures
function from the drop down menu list (Figure 10).

Figure 10.

Clear model/figures can be accessed via the main interface
A.8

4.

Element Setup
As discussed previously, the concept of ASMITA is a schematisation of the various
parts of the environment under investigation. To define the individual environment
elements the user must first know the following properties:















Type;
Name
Initial Volume;
Initial Area;
Tidal Range
Bed Slope;
Element Length;
Import Density;
Bulk Bed Density;
Transport Coefficient;
Vertical Exchange;
Regime coefficients (Vp, Sp).
Exclude element (no volume
/area change)

Figure 11.

ASMITA GUI that allows the user to enter element specific
information

Since many of the items for the specified element maybe unknown, tool tips are
provided that give the user additional information such as typical default values for a
tidal flat, channel, delta or coast. Figure 11 shows the tool tip provided for element
name.

4.1

Elements Units
Element definitions and units are defined in the element specification GUI
(Figure 11), this information is presented in Table 1.
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Table 1.

Element unit definitions and associated default values where
appropriate

Parameter
Type
Initial Volume
Initial Area
Tidal Range
Bed Slope
Element Length
Import Density
Bulk Bed Density
Transport Coefficient
Vertical Exchange
Coefficient k (Vp)
Coefficient k (Vp)
Note:

4.2

Units
Flat, Delta, Channel
m3
m2
m
n/a
m
kg/m3
kg/m3 (default value 1350)
no units (default value 2)
m/s
no units
no units

A number of sensitivity runs should be performed by the user to determine how
sensitive the system is to the information specified in the element and system
specifications.

Defining Elements
As discussed previously, elements within the environment under investigation can be
schematised into various parts depending on the individual characteristics, for
example an element defined as a channel may have distinct properties compared
with an element defined as intertidal and so on. To define an element the user must
select the Setup → Element → Define item from the drop down menu item
(Figure 12).
After selecting the Setup → Element → Define function, using the mouse draw a
rectangle on the ASMITA interface. To draw (define) the element, select the position
of the top right hand corner. Whilst holding down the left mouse button, drag the
mouse until you have reached the desired size for the element (rectangle). (Figures
12 and 13) illustrate this concept.
Note:

The size of the rectangle drawn plays no part in the calculation, the rectangle only
represents the schematisation of the environment under investigation.
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Define position

Figure 12.

Step one: define element position within the ASMITA interface

New Element

Figure 13.

Step two: new defined element within the ASMITA interface

A.11

No overlapping of elements is allowed, and no more than 20 elements can be
specified in the current version (Version 1.3). It is recommended that the user define
at least two elements and that the user allow for a suitable gap between elements,
this ensures easier selecting of elements.
Note:

4.3

The order of the elements specified by the user determines the order in which they are
stored within the Matlab data structure.

Element Properties
After defining a new element the user is asked to provide the information specific to
this element type (Table 1). Where possible, default information is provided; this
information is displayed as tool tips (Figure 11) when the user hovers over the
specific element property.
Note: Default information is not element specific.
To select the element property the user can right click on the specific element, and
then select Properties. The selected element will be highlighted in red as shown in
(Figure 14). Alternatively, the user can select Setup → Element → Properties from
the drop down menu list. The last element selected will be chosen, if no elements
have been selected in that session, then no element properties will be highlighted.
Note:

The right click method is the recommended approach.

Figure 14.

Element specification GUI
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4.3.1

Equilibrium Volume and Area coefficients
The tidal flat and channel equilibrium conditions are specified by linear equations as
a function of tidal prism of the form:
Ve = kv*Vp and Se = ks*Sp,
Where:
Sp = Vp/tr
Ve and Se are the equilibrium values,
kv and ks are the scaling coefficients,
Vp is the tidal prism and tr is the tidal range.
A unique value of kv and ks can be specified for each element using the input boxes
‘Coefficient k (Vp)’ and ‘Coefficient k (Sp)’. When a delta element is included, the
delta equations are also multiplied by kv and ks, so they can be used to re-scale the
delta equilibrium equations.
If the values of ‘Coefficient k (Vp)’ are left at the default value of 1 for ALL elements,
the model defaults to calculating the values of kv and ks internally. This is done
using the initial values of element volume and tidal prism for kv and element surface
area and prism area, Sp, for ks.
If the values of ‘Coefficient k (Vp)’ and set to 0 in ALL elements the code uses the
hypsometry routine to calculate Ve and Se (see Appendix A for details).
If any of the values of ‘Coefficient k (Vp)’ differ from 1 or 0 the code uses the userdefined values in the linear equations noted above.

4.4

Deleting Specific Elements
To delete an element from the ASMITA interface the user should right click on the
element to be deleted. From the menu items, select Delete. A popup window will
appear asking the user to confirm this action, click yes to permanently delete this
element.
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4.5

Defining Flow and Diffusion
One of the main drivers within the ASMITA model is the flow and diffusion of
sediment into and out of the specified elements, either from one element to another,
or to and from the surrounding environment.
Summary of defined Flow pathways:




Element to Element Flow;
Environment to Element Flow; and
Element to Environment Flow.

In order to specify the flow from Element to Element the user should right click on
the specified element in which they want the flow to originate, and select Flow from
the popup menu. A window will appear showing the specified element flow
arrangement (Figure 15), the user should then click on the element in which they
wish the flow to enter. After specifying the second element a textbox will appear on
the flow specification window, the user should define the rate here.
To specify flow from Element to Environment, the user should follow the method
stated above, however, rather than selecting a second element the user should click
outside any elements within the ASMITA interface (Outside environment).
To select the Environment to Element the user has to access the Flow method
from the main menu drop down list. The user should select Setup → Element →
Flow, using the mouse click onto the Outside Environment. The user can then
select the element in which flow will enter from the outside world.

ASMITA Interface or
Outside Environment

Figure 15.

Definition of the flow/diffusion through the various pathways
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The process is similar for defining the diffusion between elements. However,
diffusion is non-directional and so one can either select an element and select
Diffusion from the popup window, or access the same utility using Setup →
Element → Diffusion. Popup windows guide the user to select elements and enter
diffusion rates. The order in which elements or the Outside Environment are
selected does not matter.

4.6

Defining Change
Changes can be defined as one or more adjustments to the volume and/or area of
individual elements to represent alterations to the system. The user can specify
specific periods where a known change in an element may have occurred, for
example a capital dredge or some engineering works, or a repeating cycle such as
may be needed to represent maintenance dredging.
To specify a change in the element the user should select Setup → System →
Change (Figure 16). The user is provided with 3 options New, Edit and Load, each
menu item refers to a excel sheet that can be generated from within the ASMITA
interface by selecting New.

4.6.1

New
After selecting New (Figure 16), a spreadsheet (‘Change.xls’) will be generated. All
previous information stored in the ‘Change.xls’ file will be lost, a warning dialog will
appear to remind user of this. A separate sheet will be generated for each element
that has been defined by the user. Each worksheet (numbered 1 to n) will have the
following header information:
Element Name
Ri.fl-flat
Year

Volume

Area

Year of change and
associated change in
volume/area (m3, m2)

The user then selects a year (within the specified simulation period) and the change
in area and volume associated with that year. The user must enter the year of
change in ascending order e.g. 2000, 2004, 2005 and so on. The user can specify
the change to either all elements or a selection of elements.
Note: The change specified is specific to the number of elements and period of the model. The
generation of the ‘Change.xls’ may take several minutes.

4.6.2

Edit/Load
The user can load or edit an existing ‘Change.xls’ file by selecting Setup → System
→ Change → Edit/Load. After selecting either Edit or Load the ‘Change.xls’ file will
open and the user will be able to amend this. The user must then close Excel before
moving on to other operations within the ASMITA program. Matlab will determine
when the ‘Change.xls’ file has been closed and prompt the user to update the global
variables. Selecting yes will update the system change variables within the global
defined variables.
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Figure 16.

Popup change window for selected element

5.

System Setup

5.1

Properties
System properties are not element dependent, that is to say the information defined
within the system properties represents the whole environment. The system
properties include:









Tidal Range;
Global Sediment Equilibrium Concentration;
Water Density;
Sediment Density;
Sea Level Rise (SLR);
Cyclic information:
Number of cycles;
Phase;
Amplitude;
Period;
Project Details:
Name;
Scenario;
Date;
Tidal amplitude factor (LW/HW)

The user can access the system properties by selecting Setup → System →
Properties from the menu drop down list (Figure 17). Again, tool tips are provide for
system properties information to help assign default values and provide additional
background information.
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Figure 17.

6.

Element specification popup window

Configure Time Step
The number of time steps represents the length of time the simulation will be run. For
example, (Figure 18) shows 1120 time steps at an interval of 0.5yrs starting from
year 1500. In this example, the model will run for the period 1500 to 2060 and will
calculate the change in element areas and volumes at an interval of 0.5 years. The
fixed surface check box is used to calculate the volume and areas based on a fixed
surface area (defined as the starting level). Leaving this box unchecked means that
the surface area varies with time, as well as the volume, in response to the applied
conditions
Summary of time step configuration parameters:







Size of time step (years);
Number of time steps (years);
Start year (year); and
Fixed surface calculation (optional).
Equilibrium includes flow (optional)
Include user defined changes (optional)

To access the time step configuration window select Setup → Time Step from the
main menu drop down list (Figure 18).
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Select Setup →
Time Step

Figure 18.

6.1

Configuration Time Step window

Use Fixed Surface Areas (Optional)
When this box is checked, the initial area of each element is treated as a constant.
This reproduces the original ASMITA model that only considers changes in volume.

6.2

Equilibrium Includes Flow (Optional)
When a flow through the channel elements (and delta) is specified, this can be
considered as a perturbation to the equilibrium condition, or implicit in it. For the
former this flag is left unchecked. Where initial values are used to define the
equilibrium coefficients (see Section 4.1 and Appendix) it is implicit that the initial
condition is being defined as an equilibrium state. By checking this flag, a correction
is applied such that, at equilibrium, the rate of change is zero, including the flow.

6.3

Include User Defined Changes (Optional)
Changes to the system imposed by the user for defined years (section 4.6) in the
‘Change.xls’ file) will be included in the ASMITA equations.

A.18

7.

Running ASMITA

7.1

Check Input
After defining the individual elements and assigning the element and system
properties the user has the option to check the input data and run the ASMITA
model. The Check Input function checks all data entered to ensure consistency. The
diagnostic information is reported back to the Matlab command window (Figure 19), a
dialog box will also appear if all values specified with ASMITA are correct. Note the
Check Input function is called when the user chooses the Run Model option.
However, it might be more convenient to establish the model setup without actually
running ASMITA, in this circumstance the user should select the Check Input
function. Missing or inconsistent values will be reported to the user who will then be
able to address these errors.
To access the Check Input function the user should select Run – Check Input from
the main menu drop down items (Figure 20).

Diagnostic information

Figure 19.

7.2

The Matlab command window where the diagnostic information
is reported back to the user

Run Model
To run the ASMITA model the user should select Run → Run Model from the main
menu drop down list (Figure 20).

A.19

Figure 20.

The Check Input and Run Model menu items

After selecting the Run Model option the ASMITA program will evaluate the data
entered by the user. Before the model is initiated the ASMITA program asks for a file
name (Figure 21) with NO extension. After running ASMITA there will be two output
files. One will be a text file with the setup information and a second spreadsheet file.
The spreadsheet will contain results from the model simulation as well as the setup
information. The name of both the text and spreadsheet files are identical, except for
the file extension.

Figure 21.

8.

Dialog box asking for user defined name

Results
The results that can be obtained from ASMITA to inform the user of the
consequences of an engineering project, dredge, and climate change and so on are
the following:
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Volumes/Areas:

Moving Surface Volume/Area (values relative to any changed water level);

Equilibrium Volume/Area (values that determine the equilibrium condition);
and

Fixed Surface Volume/Area (values relative to a fixed (initial) water level).

9.

Plotting Routines
In order to visualise the results generated by the ASMITA model a plotting routine
has been developed (Figure 22). To access the plotting routine select Plot → Plot
Results from the drop down menu item.
There are no limits to the number of plot windows, the user can clear individual
windows by clicking on the cross in the top right hand corner. The user can clear all
plot windows by selecting the Tools → Clear → Clear Model function (Section 3.3).
The plotting routines will not allow identical parameters for the same element to be
plotted on the same figure. By design, selected parameters will be added to the last
active figure.

Choose between elements
defined in ASMITA model

Option to display area and
volume information

The user can create a new
plot or add to an existing
figure. The user can delete
data from a current plot
figure

Figure 22.

Plot specification window, allows the visualisation of ASMITA
results

A typical example of the output from ASMITA is displayed in Figure 23. The user can
access this data either through Matlab or from the stored data in the spreadsheet.

A.21

Results from selected element.
Each parameter is represented
by a different colour

Figure 23.

9.1

Example of results generated using ASMITA

Parameter Definitions
The output parameters from the ASMITA model are:

1

Moving Surface Volume

The volume below a water level that may rise and fall
over the simulation period depending on the input
parameters e.g. climate change, nodal cycle and so
on1. The moving surface volume describes the
combined morphological and water level change in the
element.

Equilibrium Volume

This depends on the formulation used to define the
equilibrium condition (see Appendix) but is typically
some function of the tidal prism. The equilibrium
volume describes the volume that the element will try to
adjust towards at any given point in time1.

Fixed Surface Volume

The volume below a fixed water level defined by the
water level at the start of the simulation1. The change in
volume represents the morphological change in the
element.

Moving Surface Area

This is the plan area of the element at the water level at
each time interval. Like the moving surface volume it
reflects both morphological and water level changes.

Equilibrium Surface Area

This depends on the formulation used to define the
equilibrium condition (see Appendix) but is typically
some function of the tidal prism. The equilibrium

This will be a wet/water volume if the transport coefficient for the element is positive,
otherwise it will be a dry/sediment volume
A.22

surface area describes the area that the element will try
to adjust towards at any given point in time.
Fixed Surface Area →

The surface area at a fixed water level defined by the
water level at the start of the simulation. The change in
surface area describes the morphological change in the
element.

The output parameters from the ASMITA model can be used to inform the following:




How elements change over time, responding to perturbations (e.g. dredging
and reclamations) or ongoing changes (e.g. sea level rise and changes in
tidal range).
The response in a moving frame of reference (moving surface) and fixed
frame of reference (fixed surface).
The morphological phase lag and damping, based on the differences between
the moving and equilibrium values

Volumes, comparisons of the various volumes help the user define the effect of
changes to the element. In particular, differences between the fixed and moving
surface may inform the user of the effects (import/export of sediment by subtracting
the moving from the fixed values) of sea level rise within the specified element.

10.

Program Structure
Procedure Name

Description

vardef
defglob
moddef_fig
cb_fil1
cb_fil2
cb_fil3
cb_fil4
cb_elm1
cb_elm2

definition of variables
definition of global variables
model definition (figure)
menu item 'file, open'
menu item 'file, save'
menu item 'file, save as'
menu item 'map'
menu item 'element, define'
menu item 'element, specify'
element specification form (figure)
button 'ready' in this form
menu item 'element, delete'
discharge related exchange between elements
discharge specification form (figure)
button 'ready' in this form
diffusion related exchange between elements
diffusion specification form (figure)
button 'ready' in this form
menu item 'run, set time step'
time step specification form (figure)
button 'ready' in this form
menu item 'run, check input'
write input data to file
menu item 'run, run model'
model
model
graphs of computational results
menu item 'exit'
draw worksheet and background map, if applicable
select element by clicking on it
find or set reference to information on exchange between
elements

elspec_fig
cb_spec
cb_elm3
cb_excq
excq_fig
q_ready
cb_excd
excd_fig
d_ready
cb_run1
timest_fig
cb_run1a
cb_run2
cb_print
cb_run3
asmita
eq_vol
cb_graph
exit_fig
drawmap
getelem
getindex
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Area and volume changes in an estuary
Introduction
ASMITA (Aggregated Scale Morphological Interaction between a Tidal Basin and the Adjacent coast,
Stive et al. 1998) is an approach developed for the study of estuary response to sea level rise. The
model is based on an aggregated model that considers the estuary as a box (or set of boxes) that fills
and empties under tidal action. The methodology was developed to look at the combined response of
tidal delta, channel and tidal flats and has been applied to the impact of sea level rise on tidal inlets
(van Goor et al. 2003) and the response of an estuary to the nodal tidal cycle (Jeuken et al. 2003).
This note summaries the basis of the ASMITA model, combining multiple elements with marine and
fluvial sources. In addition the existing ASMITA, which only considers variations in estuary volume,
is extended to represent time varying surface area. This allows perturbations to be introduced in the
form of changes to the volumes and areas due to interventions such as dredging and reclamation, as
well as sea level rise and cyclic variations in the tidal range. The basis of the empirical relationship
used to define the equilibrium relationships is also given some further consideration.
Single element volume model
For a single element model, comprising just an estuary channel, the equilibrium state is derived from
the equilibrium relationship assumed between the channel volume and the tidal prism:
(1)

Vce = f(P)
Where Vce is the equilibrium volume of the channel and P is the tidal prism (Eysink, 1990).

The other assumption made is that the ratio of the actual flow velocity to the equilibrium condition is
proportional to the ratio of the equilibrium volume and actual volume. The local equilibrium
concentration can therefore be written in terms of the actual volume, V, and the equilibrium volume,
Vce:

⎛V
c ce = c E ⎜ ce
⎜V
⎝

⎞
⎟
⎟
⎠

n

(2)

Here cce is the local equilibrium concentration, n is the concentration transport exponent and cE is the
equilibrium concentration for the system as a whole (usually taken as the open boundary value). The
difference between the actual concentration and the local equilibrium value induces morphological
change governed by the exchange between the water column and the bed:

dV
= wS (c ce − c )
dt

(3)

Where w is the vertical exchange coefficient, S is the surface or plan area of the channel and c is the
actual concentration. If we now consider a sediment balance where the (long-term residual) sediment
transport between elements is assumed to be simply diffusive (in this case the channel and the
external environment):

wS (c ce − c ) = δ co (c − c E )

ASMITA manual App v1 3 May08 (2).doc

1

(4)

17/09/2008

ASMITA Manual
The parameter δco is the horizontal exchange coefficient and the r.h.s. of equation (4) represents the
exchange with the external environment.
Combining equations (2)-(4) and adopting a simple linear relationship for equation (1) of the form
Ve=αP, where α is an empirical coefficient, the moving surface volume, Vm, is given by:

dVm wδ c E S
=
δ + wS
dt

⎡⎛ V (t ) ⎞ n ⎤ dς
η
⎢⎜⎜ e ⎟⎟ − 1⎥ +
⋅ S + iω e iωt ⋅ S
2
⎢⎣⎝ Vm (t ) ⎠
⎥⎦ dt

(5)

Which includes the variation in volume due to sea level rise and the some cyclic variation in tidal
range, such as the nodal tidal cycle.
In this form, the equilibrium volume, Ve, and the fixed surface volume, Vf can be written:

Ve (t ) = α ⋅ P = Vo + α ⋅ ΔP
ΔP = η ⋅ e iωt ⋅ S
V f (t ) = Vm (t ) −

(6)

dς
η
⋅ S ⋅ t − e iωt ⋅ S
dt
2

Where the variables are defined as follows:
Ve – equilibrium volume
Vo – initial volume at time t=0
Vm – moving surface volume
Vf – fixed surface volume
P – tidal prism

ζ – vertical sea level movement
ω – angular frequency of nodal tide
η – amplitude of nodal tide
S – surface area of basin
n – sediment transport exponent,
usually taken as ~2.

w – vertical exchange rate
δ – horizontal exchange rate
cE – global equilibrium
concentration

In this simple model the plan area is treated as constant. On the basis that Ve ~ fn(P) any hydraulic
changes that result in a change in tidal prism are represented in Ve but those that change the volume of
the system (such as sea level rise, dredging or reclamation) are represented in Vm.
The variation in equilibrium, moving and fixed estuary volumes, due to a linear rise in sea level and
the nodal tidal cycle, are illustrated in Figure 1. The lag and damping of the response, relative to the
equilibrium volume, is due to the dynamics associated with the morphological response time of the
estuary (Jeuken et al. 2003).
The reduction of the volume relative to a fixed surface, shown in Figure 1, reflects the infilling of the
basin that takes place, in order for the morphology to warp up vertically to keep pace with sea level
rise (and the superimposed nodal cycle). Thus, vertical translation of the system is incorporated in
this model. If, however, we wish to include the possibility of horizontal translation, as well as the
vertical response, it is necessary to adjust the plan area rather than treat it as constant.
In this formulation, the morphological timescale is determined by n and cE. In addition, the horizontal
exchange is related to the vertical exchange as a function of hydraulic depth and velocity. This means
that by defining the vertical exchange, w, and the sediment transport exponent, n, based on the
sediment characteristics of the estuary, and the global equilibrium concentration, cE, to give the
correct morphological time scale, the horizontal exchange coefficient is scaled by some factor, ε, to
calibrate the model (see Wang et al. 2007 for further details).
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Multi-element volume model
The basic concept of the multi-element model is to subdivide the estuary into a number of elements
and define the exchanges between elements and the equilibrium conditions for each element. As
already noted, this has been presented in the literature as the ASMITA model (Aggregated Scale
Morphological Interaction between a Tidal basin the Adjacent coast) and was introduced by Stive et al
(1998; see also van Goor et al. 2003; and Kragtwijk et al. 2004). The system can be schematised
into any number of discrete elements, which might be sections along the channel as used in
ESTMORF (Wang et al. 1998), or geomorphological components, such as the channel and tidal flats
as typically used in ASMITA. This is illustrated in Figure 2, which shows the linkage between tidal
flat, channel and tidal delta through to the open sea, referred to as the outside world. For each
component the volume can be defined in terms of the sediment or water volume. In the derivation
presented here, only water volumes are used and the equations presented reflect this (for the more
general case see the papers noted above). So, for example, the scheme shown in Figure 2 would be
represented by:
Tidal delta Channel Tidal flats -

total water volume over delta (where the delta has a volume relative to undisturbed
coastal bed)`
total water volume below MLW
total water volume between MLW and MHW over flats (i.e. not including the prism
over the channel)

The variation in these volumes depends on the transport of sediment in and out of the elements and
any changes to the water volume itself. The latter may be due to sea level rise, subsidence of the bed,
or any form of progressive change in the basin volume. Hence, over the long-term (time scales much
longer than a tidal cycle) the rate of change of the element volume depends on the residual flux, the
change in sea level as follows and any change in tidal range:

dVi
dζ
d (tr )
= ∑ J i , j + Si
+ Si
dt
dt
dt
j

(7)

where J is the sediment volume flux between elements i and j, S is the plan area of the element and ζ
is the elevation of mean sea level. The residual sediment flux between two elements is assumed to
have advective and diffusive components:

J i , j = qi , j ⋅ ci − q j ,i ⋅ c j + Di , j Ai , j

∂c
∂x

(8)

where q (m3s-1) is the residual discharge rate (qi,j ≠ qj,i), D (m2s-1) is the diffusion coefficient between
the two elements, A (m2) is the vertical area of the interface between the two elements and the sign
convention reflects the change to the water volume. This can be written in a form similar to the r.h.s.
of equation (4):

J i , j = qi , j ⋅ ci − q j ,i ⋅ c j + δ i , j ⋅ (ci − c j )

(9)

In equations (8) and (9) the subscripts i and j refer to the elements the transport is from and to
respectively. The advective component assumes that the concentration of the flux is that of the
element supplying the sediment, which is important for external inputs such as from the rivers. In
contrast the diffusive component simply uses the gradient between the elements.
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The equations presented for the single element model can be conveniently written in matrix form to
represent a multi-element model. Here we follow the naming convention of Kragtwijk et al (2004) for
volumes and add some additional terms to make the model more general with respect to diffusion,
advection and the sources of perturbations in the volume.
Vectors are defined for a number of the variables as follows:
V

element volumes

γ

volume ratios (Vke /Vk)n

S

element surface areas

σ

surface area ratios (Ske /Sk)abs(n)

ce

local equilibrium concentrations

δ E horizontal exchange coefficients with environment

c

element concentrations

n concentration transport exponent. positive for wet
volumes and negative for sediment volumes

cext concentrations for fluxes into the
system from the environment

In addition use is made of the following diagonal matrices:
W
vertical exchange coefficient w;
S
surface areas;
I
unit or identity matrix;
M
unit matrix with sign of n.
The matrix D reflects the structure of the horizontal exchange between elements and with the outside
world. For an n-element system with all elements linked and exchanging sediment with external
environments, this would take the following form:

⎛
⎜
⎜ ∑ δ1,n + δ1, E
D=⎜
− δ 2,1
⎜
⎜ ...
⎜
− δ n ,1
⎝

− δ1, 2
∑ δ 2,n + δ 2, E
...
− δ n, 2

...
...
...
...

⎞
⎟
− δ1,n
⎟
⎟
− δ 2,n
⎟
...
⎟
∑ δ n,n + δ n,E ⎟⎠

(10)

For a 3-element system in which only element 3 is connected to the external environment (e.g. a tidal
flat, channel and delta) this would take the form:

⎛ δ1, 2
⎞
− δ1, 2
0
⎜
⎟
− δ 2,3 ⎟
D = ⎜ − δ 2,1 δ 2,1 + δ 2,3
⎜ 0
− δ 3, 2
δ 3, 2 + δ 3, E ⎟⎠
⎝

(11)

For diffusion the matrix is symmetric because δi,j = δj,i and the direction of transport depends on the
concentration gradient. However, for residual discharge the transport has a specified direction and as
already noted we adopt the convention of transport from element i to element j. The matrix for an nelement system is then given by:
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⎛
⎜
⎜ ∑ q1,n + q1, E
Q=⎜
− q2,1
⎜
⎜ ...
⎜
− qn ,1
⎝

− q1, 2
∑ q2 , n + q2 , E
...
− qn , 2

...
...
...
...

⎞
⎟
− q1, n
⎟
⎟
− q2 , n
⎟
...
⎟
∑ qn,n + qn,E ⎟⎠

(12)

Where qn,E all relate to fluxes out of the system. In order to ensure continuity of water mass we also
require that, for each element, the sum of the discharges in and out of the element is zero,
i.e. Σ qi = 0. 1
The basic equations can now be written:

dV
= MWS (ce − c)
dt
(D + QT )c = WS(ce − c) + cE δ ext + kc ⋅ qext

(

ce = cE γ

and kc =

)

(13)

cext
cE

From which the following expression can be derived for the rate of change of volume (note the vector
d has the opposite sign to that given in equation (17) of the paper by Kragtwijk et al):

dV
dζ
d (tr )
= Bγ − d + S
+ S . × trs
+ ΔV
dt
dt
dt
where

(14)

−1

B = cE MWS(I − (D + Q + WS) WS)
T

d = cE MWS(D + QT + WS) −1 (δ ext + kc ⋅ qext )
Here tr refers to the tidal range and the expression . × trs refers to element by element multiplication
by ½ with a sign that reflects whether the element is influenced by high or low water. The term ΔV
refers to any other changes in volume, introduced at any given time, within each element, e.g. due to
reclamation or dredging.
Equilibrium and fixed volumes then have a similar form to equation (6), where δtr is the variation in
the tidal range from its mean value:

Ve = α ⋅ P = Vo + α ⋅ ΔP
V f = Vm − S ⋅ ζ − S . × trs ⋅ δ tr

(15)

The relationship between estuary volume and surface area
As estuaries vary throughout their length, the change in depth is generally much smaller than the
change in width. This obvious statement induces a corollary that the tidal, wave, fluvial and
geotechnical effects that define an estuary geometry induce much larger changes to the width of a
cross-section than to the depth. In addition, the downstream part of an estuary, which is
predominantly tidal, tends to experience less proportional change in depth with distance than the head
1

However, provision is made for the sediment concentrations associated with these discharges to vary.
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of an estuary which is much more affected by fluvial discharges. Since the volume and surface area
within an estuary tend to be dominated by the much wider and deeper downstream reaches, where
cross-section area correlates highly with width, estuary volume also tends to correlate highly with
surface area.
Figure 3 indicates how in simple terms a change (δA) in channel cross-section area can be related to
the change in width (δW), i.e.. δA= h.δW. Because of the above arguments it is possible to extend
this idea to surface area (S) and volume (V), i.e. δV= h.δS . Moreover the same argument can be
made for change in tidal flat volume and surface area.
Variable Surface Area
For a single element (such as a channel) linked to the open sea, the above arguments lead to the
following expression (in the absence of sea level rise and tidal node variation):

dS 1 dVm 1 wδ c E S
= .
= .
dt h dt
h δ + wS
where:

qˆ =

⎡⎛ V (t ) ⎞ n ⎤ wˆ δˆ c S
E
⎢⎜⎜ e ⎟⎟ − 1⎥ =
ˆ
V
t
(
)
⎢⎣⎝ m ⎠
⎥⎦ δ + wˆ S

q
δ
; δˆ =
h
h

and ŵ =

⎡⎛ S (t ) ⎞ n ⎤
⎢⎜⎜ e ⎟⎟ − 1⎥
⎢⎣⎝ S m (t ) ⎠
⎥⎦

w
h

(16)

(17)

The effect of sea level rise and nodal tide variation is included by considering the change in surface
area that arises from a change in mean sea level and a change in tidal range. The non-linear equations
(for the single element model) describing the variation in surface area are therefore similar to equation
(5) and (6) for volumes, viz:

P
ΔP
= S o + αˆ ⋅
tr
tr
2
⎤ dς
dS m wˆ δˆ c E S ⎡⎛ S e (t ) ⎞
η
⎟⎟ − 1⎥ +
⎢⎜⎜
=
⋅ R + iω e iωt ⋅ R
ˆ
dt
2
δ + wˆ S ⎢⎣⎝ S m (t ) ⎠
⎥⎦ dt

S e (t ) = αˆ ⋅

S f (t ) = S m (t ) −

(18)

η
dς
⋅ R ⋅ t − e iωt ⋅ R
dt
2

The parameter R represents the change in area for a unit change in water level and is given by
R=k.Lmb, where k is the number of bed surfaces in the element (generally 2 for the two sides of the
estuary), mb is the transverse bed slope (i.e., slope is given by the ratio 1:mb) and L is the length of the
element.
As for volumes, this can be applied to multiple elements, extended to include advective flow, and the
rate of change for the surface area S, is given by:
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dS
dζ
d (tr )
= Fσ − e + R
+ R. × trs
+ ΔS
dt
dt
dt
where
ˆT +W
ˆ S (I − ( D
ˆ +Q
ˆ S) −1 W
ˆ S)
F = c MW

(19)

E

ˆT +W
ˆ S(D
ˆ +Q
ˆ S) −1 ⋅ (δˆ + k ⋅ qˆ )
e = c E MW
ext
c
ext
⎛ Se ⎞
σ =⎜ ⎟
⎜ Sm ⎟
⎝ ⎠

abs ( n )

ˆ , δˆ and W
ˆ are derived from D, δ E and W in accordance with equation (17). The
where D
E
equilibrium and fixed surface areas then have a similar form to equation (15):

S e = αˆ ⋅ P = S o + αˆ ⋅ ΔP

(20)

S f = S m − R ⋅ ζ − R. × trs ⋅ δ tr

Tidal Prism Relationships
Equation 1 postulates a link between the equilibrium volume and the tidal prism. Similarly the value
of the equilibrium surface area Se in Equation 17 is likely to vary with the tidal prism. Townend
(2005) showed that the tidal prism exhibits a strong correlation with the plan area and volume of the
estuary. From a sample of 66 UK estuaries he found that the total surface area, total volume and tidal
prism exhibited the following relationships:
Smtl = 0.42P0.96,
Vmtl = 0.073P1.13,

R2 = 0.92;
R2 = 0.92.

(21)

The elements used within ASMITA comprise deltas, channels and tidal flats. The UK estuaries
database suggests that the channels and flats (when represented as a single element) can be adequately
represented by simple linear relationships with exponents of one:
Table 1 Linear form-prism ratios

Channel
Tidal flats

Volume
Vc = 0.418P
Vf = 0.163P

R2
0.93
0.74

Surface Area
Sc = 0.076P
Sf = 0.077P
Sf = 28.9P0.75

R2
0.95
0.47
0.82

However, individual estuaries can have values significantly different from the above. The following
are the average values for the Humber over the period 1851-2000 (based on 22 bathymetric data sets)
with standard deviations indicating a small variation over time:
Table 2 – Linear form-prism ratios for the Humber Estuary

Channel
Tidal flats
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Vc = 0.738P
Vf = 0.249P
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St.dev Surface Area
0.021 Sc = 0.130P
0.011 Sf = 0.067P

St.dev
0.003
0.003
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One of the strongest correlations revealed by the UK data is between the surface area at mean tide
level, prism and tidal range, which takes the form:

S mtl = 1.07

P
tr

(R2 = 0.996)

(22)

This implies that the tidal prism is essentially the plan area at mean tide multiplied by the tidal range
(particularly for the larger estuaries with P>107m3) and that the cross-shore shape of the intertidal is of
secondary importance. Although the regression is strong it must be recognised that the error in
predicting the plan area of an individual estuary can still be ±30% based on this data set, with most of
the data points falling below this forced regression line (i.e. exponent=1 and intercept=0). The
surface area at low water is also reasonably well represented by this form of relationship but the area
of the tidal flats shows a poorer correlation, Table 3. The coefficients specific to the Humber are
similar for the mean tide and channel (mlw) relationships but differs significantly for the tidal flats.
Table 3 Linear form-prism ratios for surface area as a function of P/tr

Channel
Tidal flats
Mean tide level

UK estuaries
Sc = 0.775P/tr
Sf = 0.945P/tr
Smtl= 1.07P/tr

R2
0.97
0.77
0.99

Humber estuary
Sc = 0.733P/tr
Sf = 0.386P/tr
Smtl = 0.96P/tr

Hypsometry Relationships
An alternative approach is to use the equilibrium hypsometry relationships for channels (Cao &
Knight, 1997) and tidal flats (Friedrichs & Aubrey, 1996) to define the form of the estuary crosssection. The resulting relationships can then be written in terms of volume and surface area by
considering a representative length. Some trials for a number of estuaries suggest that this form
description provides a reasonable characterisation of estuary cross-sections.
Friedrichs and Aubrey (1996) show that the lower intertidal width is a function of the equilibrium
flow velocity and the angular tidal frequency: (wo-wlw) = ueq/ω. This implies that the lower intertidal
width reflects flow field, the erodibility of the sediments and the rate of convergence of the estuary.
We therefore assume that the slope of the lower intertidal is a characteristic value, which in terms of
surface area is given by:

meq =

S o − S lw
2η

(23)

Using the initial estuary surface areas at mtl and lw, with the tidal range, the equilibrium slope can be
calculated using equation (23). Similarly, the d-n ratio = (d-η)/(n+1) can be obtained as the ratio of
the volume and area at low water. If the slope and d-n ratio are treated as being constant, equations
(24) can be used to derive updated equilibrium volumes and areas for the channels and flats given a
new value of the tidal prism.

1
(
V p − (1 + π ) ⋅η 2 meq )
2η
⎛ π⎞
S fl = ⎜1 + ⎟ ⋅ 2η ⋅ meq
2⎠
⎝
S lw =

Vlw =

d −η
⋅ S lw
n +1

(24)

V fl = (1 + π )η 2 meq

Fitting (24) to the UK estuaries database produces reasonable fits to the data. In particular, Vlw is well
represented and the fit lines go through the centre of the data, whereas for Vfl, and Sfl the fitted lines
represent lower bounds.
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Basis of equilibrium volumes and areas in ASMITA
The ASMITA model, as presented, makes use of the general nature of the results described above and
provides the user a number of options.
(i)
Equilibrium based on linear tidal prism functions
This method assumes that the governing equation for equilibrium volume is a linear function of the
tidal prism and for surface area is a linear function of prism/tidal range. The user is able to set the
values of the proportionality coefficients separately for each element. In the code the default values
for these coefficients are 1 and if these are used, the routine calculates the coefficients from the initial
values of volume, surface area, tidal prism and tidal range for each element. Thereafter, the
coefficients are treated as constants. (NB: This uses the individual element volume or surface area as
a proportion of the total upstream tidal prism.)
(ii) Equilibrium based on hypsometry functions
This method uses the initial values of volume, surface area, tidal prism and tidal range to calculate
the equilibrium slope and the d-n ratio, as defined above. These values are then treated as constants
and the equations for the equilibrium hypsometry (24) are used to compute volumes and areas for the
channels and flats, taking account of change in tidal range and tidal prism. The method is activated
by setting the volume equilibrium coefficients for every element to zero.
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Figure 1 – Variation in estuary volume for rising sea level and nodal tidal cycle as predicted by the single
element model
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Figure 2 – Schematic of elements for a tidal inlet as used in the ASMITA model
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Figure 3 – Sketch to illustrate relationship between changes in width and cross-sectional area

δW/2

δW/2

δAflat

h'
δAchan
h

0.4

0.002

0.3

0.0015

Surface area
0.2

0.001

Volume
CSA

0.1

0
0.00

0.0005

10.00

20.00

30.00

40.00

50.00

0
60.00

Distance from mouth (km)

ASMITA manual App v1 3 May08 (2).doc

11

17/09/2008

A-P ratio

S-P & V-P ratios

Figure 4 – Tidal prism ratios for Cross-section area, Surface area and volume along the Humber estuary

